首页
登录 | 注册

Linux内核RDS漏洞,影响Red Hat,Ubuntu,Debian和SUSE

如果您不习惯使用最新版本的Linux内核,那么现在可能是考虑这样做的好时机。基于早于5.0.8的内核版本的系统在通过TCP实现RDS时遇到严重缺陷。如果没有打补丁,该漏洞可能会使攻击者破坏系统。

Red Hat,Ubuntu,Debian和SUSE都受到了这个漏洞的影响,并且已经为每个Linux发行版发布了安全建议。值得注意的是,“攻击复杂性”被评为“高”,因此虽然安全漏洞的影响可能很严重,但成功攻击的变化相对较小。

Linux内核RDS漏洞,影响Red Hat,Ubuntu,Debian和SUSE

在对该漏洞的分析中,Red Hat说

在Linux内核的TCP上RDS实现中发现了一个漏洞。加载了rds_tcp内核模块的系统(通过运行listen()的本地进程通过自动加载或手动加载)可能会导致在释放后使用 (UAF),其中攻击者能够操纵网络命名空间的处理套接字状态,从而可能导致内存错误和权限提升。

再来说Ubuntu,来自Canonical的报告让你稍微放松一下,Seth Arnold说:

我还没有看到证据支持这种可以远程利用的指控。将rds.ko模块列入黑名单可能足以防止易受攻击的代码加载。自Ubuntu 14.04 LTS以来,kmod软件包的默认配置包括/etc/modprobe.d/blacklist-rare-network.conf中的RDS。结果我没有优先考虑。

不管怎样,问题已在Linux内核的5.0.8版本中进行了修补,因此如果您还没有这样做,请更新。

  • 更多Ubuntu相关信息见Ubuntu 专题页面 https://www.linuxidc.com/topicnews.aspx?tid=2
  • 更多RedHat相关信息见RedHat 专题页面 https://www.linuxidc.com/topicnews.aspx?tid=10
  • 更多SUSE相关信息见SUSE 专题页面 https://www.linuxidc.com/topicnews.aspx?tid=3


2019 monjeep.com webmaster#monjeep.com
10 q. 0.020 s.
京ICP备10005923号